State Cad Tutorial Jim Duckworth

Using StateCAD to generate VHDL from State Diagrams
Select Project => New Source and select State Diagram.
StateCAD starts

Select File => Design Wizard or click on the Draw State Machine button

Design Wizard E|
Thiz wizard automates the dezign and optimization of a zingle state machine.
StateCal supportz concurrent [multiple] state machines, different state assignment
modez, and aptimizationz. The wizard will take you thraugh the fallowing steps:

1] & basic state machine is created from templates Dasign Wizagd
2] Rezet logic iz updated
3] The deszign iz optimized with the Optimization 'Wizard

4] The deszign iz translated to synthesizable HDL

Help |

Click on Next

State Machine Wizard E|

Select the appearance Prewview
of the state machine.

Shape of state machine

TESE

" Column
" Mulbi-Column
" Row

¥ Geometric

Mumber of states [3..16]

S

Help | | < Back |

To make our SM1 state machine, select 4 states

Click on Next
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Design Wizard : Reset The State Machine

Congider the specific device being uzed when selecting
the rezet mode. For example, FPGAs often include a wvery
efficient global azpnchronous reset. Tesst

Select whether the reset iz spnchronous or asynchronous.
Later, to change reset modes, edit the reset's condition.

Reset Mode
™ Synchronous

Help | ¢ Back | Mext » Cancel

Select Asynchronous reset then Next

Design Wizard : Setup Transitions

Each state can have a transition which retuns ta it Sarnple
[loop back], as well as tranzitions going from it to the

nesxt state and previous state. The zample window

shows the effects of your selections. MEXT|

Select the transitions to be uged in the design. Later,
you can customize the design by editing or deleting the
transitions as needed. NET

Add Transitions  Set condition to

™ Loop back: |

W Mext: |

I~ Previous: | Diefault
Help | < Back |

Lancel |

The Optimization Wizard may open at this point (click cancel — we will run this later)
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Now we need to add the transitions from state to state.

Click on the transition from State0 to Statel and add EN="1" as shown:

Edit Condition 3

LCondition:
EM ="1{

Outputz:  Unazzigned outputs are made inactive (e, g=0]

Dot Wizard To edit equations created with the wizard, place
MR W2 b cursar in the equation and click Dutput
Jugtify Condition Jugtify Output

" Left & Center © Right || © Left & Center O Right

[ Mutually Excluzive [ Border p

Pricirity ID_iI Ok, |I:ancel| Help | "

Click on OK
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Repeat for the other transitions:
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File Edit Yiew
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Now we need to set the output conditions:

Double-click on State0 and add C <= ‘0’; as shown

Edit State

State Name:  |STATED

Dutputs:  Unaszigned outputs are made inactive [1Le. g=0]

C«="0"

Juigtify O ubput
" Left

Justify State Mame

(" Left ™ Center  Right

] | Cancel |

(+ Center

Output ‘wizard Create counters, muxes, ete. with the wizard.

" Right

Help

X

and repeat for the other states
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SM1.DIA - StateCAD(r) FEX
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You can go straight to Generate HDL (Options => Compile), but first click on the
Optimize button.

Optimization Wizand

Thiz wizard azks a series of guestions to zelect the best optimizations far
wour design. HOL will be optimized for the target device, synthesis tool,
and design goals. vou wil..

1] Select the target device

Cafinnize W.‘z?'d

2] Choose the type of output optimization

3] Select perfarmance optimization
4] Determing if you should uze load optimization

B] Select the target synthesis tool and HOL

Help

Optimize Wizard : Select Target Device

Global optimizations zhould be selected for the type of device being targetted.
For example, FPGAs are regizter nch, with limited logic per CLB. Select the
device type:

COFPGA

" Simulation anly

Help ¢ Back Mext » LCancel
] I
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Optimize Wizard : Optimize Qutputs

Speed optimized outputz register the next value, Area optimized outputs are
decoded after the clock. Individual outputs may be optimized in Manual mode.

State hBchine Frea Optimiz ed ([ Comrbingtorial

T

Thiz example above is optimized for area and speed. The state machine yiglds
the same output zequence, but the timing and area vary dramatically.

* tdanual " Speed [register outputs]  © Area [decoded outputs]

Help ‘ < Back | '

Cancel |

StateCAD can guarantee the state machine never gets lost, and all
conditions are covered. The price of guaranteed coverage iz increased
logic utilization, and slower state machines. [tiz recommended to uze
implied elze to minimize design errors.

\up The example shows a state with a 'loop
Tz back' condition of P, 1f thiz transition was

uE not present, then when UP=0, what iz the
nest state? Imphed elze cauzes the design
to remainz in the cument state.

¥ Guarantee coverage [implied else)  © Maximize speed, reduce area

Help | < Back |

LCancel |

Optimize Wizard : Optimize Loading

Feedback signals can be automatically buffered to ensure loading changes
outzide a state machine do not affect its clock speed.

(% Enable buffering (" Disable buffering

Loading can be reduced by making feedback signals internal nodes. StateCaD
flags feedbacks and will make them into internal nodes automatically.

[v Optimize Port 1/0: Make feedback signals intemal nodes

|Jnazzigned outputs can be retained between clocks or made inactive.
R etaining simpifies registerad outputs, but can increaze loading.

-
Help ‘ < Back |

LCancel |

Optimize Wizard : Select Target HDL

StateCAD automatically ranslates state diagrams to spnthesizable and
simulatable HOL. OF course, when you need to port a design, just change
the target HDL and recompile - StateCAD automatically generates HDL in
the new language.

Select the target HDL:

Cancel
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Optimize Wizard : Tool Vendor,

StateCAD's WHDL and Yenlog outputs should be optimized for your
sunthesiz toal bo enzure efficient results. Alzo, StateCAD automatically
works around known bugs in the synthesis tools and restructures the HOL
ta wark, aptimally far each tool.

IEEE 1076

Help | < Back | MHewt » Cancel

Click on Next to end the Optimize wizard.

Click on the Generate HDL button:

Compiled Perfectl
Ma Prablems ldentified.

Review design stahiztics below

- -

&
v & @
CHELK AHALYZE OPTIMIZE BENERATE

Summary
74 Lines of code generated s
35 K.-Bytes Memon uzed =
0.047 Seconds Compiling

L
Dezign Information
1 State Machines s
4 States o
g Tranzitions

b
Analyziz Performed
0000 Secondsalidating State Azsignments ”
0001 Seconds Locating Indeterminate Conditions
00001  Secaonds ldentifving Canflicting % ariables

L

Click on Close and the HDL code generated is shown:
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& StateCAD HDL Browser - C:\Wwhdl\statecad_sm1\statecad\SM1.vhd

File Yiew

S E | 7

— CWHDL\STATECAD_SM1\STATECAD\SM1.vhd
YHDL code created by Xilinx's StateCAD 6.1i
— Sun Mar 28 15:35:23 2004

This YHDL code [for use with Xilinx X5T) was generated using:
— binary encoded state assignment with structured code format.
— Minimization is enabled, implied else is enabled,

— and outputs are manually optimized.

LIBRARY ieee;
USE ieee.std_logic_1164.all;

ENTITY SM1 15
PORT [CLK,EN.RESET: IN std_logic:
C: OUT std_logic);

END;

RCHITECTURE BEHAVIOR OF SM1 IS

SIGNAL sreg : std_logic_vector [1 DOWNTO 0);

SIGNAL next_sreg : std_logic_vector [1 DOWNTO 0);
CONSTANT STATED : std_logic_vector [1 DOVWNTO 0] :="00";
CONSTANT STATE1 : std_logic_vector [1 DOVWNTO 0] :="01'%
CONSTANT STATEZ : std_logic_vector [1 DOVWNTO 0] :="10';
CONSTANT STATE3 : std_logic_vector [1 DOWNTO 0] :="11'%

|BEGIN
PROCESS [CLK, RESET, next_sreqg)
BEGIN
IF [ RESET="1"] THEN
sreg <= STATED;
ELSIF CLK="1" AND CLK'event THEN
sreg <= next_sreq;
END IF;
END PROCESS;

PROCESS (sreg.EN]
BEGIN
C<="0%

next_sreg<=STATED;

CASE sreg IS
WHEN STATED =>
C<="04
IF[EN="1"] THEN
next_sreg<=STATE1;
ELSE
next_sreg<=STATED;
END IF;
WHEN STATE1 =>
C<="04
IF[EN="1"] THEN
next_sreg<=STATEZ;
ELSE
next_sreg<=STATE1;
END IF;
WHEN STATEZ2 =>
C<="04
IF[EN="1"] THEN
next_sreg<=STATE3;
ELSE
next_sreg<=STATE2;
END IF;
WHEN STATE3 =>
ce="1
IF[EN="1"] THEN
next_sreg<=STATED;
ELSE

Ready
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You can change the generated VHDL by Options => Configuration

Configuration E‘
Options Cheek For
WpMmmze ¥ Indeterminate Transitions
¥ Full Vector Support W Unused Intemal Nodes Cancel
¥ Add Varishles Automaticaly ¥ Conflicting State Assignments
¥ Delete Unused Yariables W Output Variable Corflicts
il he v [ ]
I Retain Output Walues I Stuck At States and Outputs
¥ Guarantee StateBench Checks [V Missing Reset Lagic
State Assignment | | Language Generation Options
" Marual * Stuctured © Boolean g
& Binay Encode: [¥ Buffer feedback signals (v

 Dne Hot I Spnopsys syle L
 Enumerated - r
= ~

Brawser Control

 Default browser ¥ Show after compile | Use pour browser. J

Optimize Include  lbrary fles Lanquags Yendor
@ ) EEE 1076

¥ Clock court Synopsys/FRGA Express
 Speed
" Brea
¥ Patl F F

Click OK or Cancel.

Click on the State Bench button then click on Automatic Test Bench

I SM1.DIA - [VHDL] - StateBench(tm)
File Options View Help

s =] == oy sz =z A
5| | e TS | |-l |0 IR e | 92 @

Beh Restart | Reset | Cosle | |Find EventiBreakpoint] pipg Bench_|TestBench| | Stalistics | Timing_ | Testbench| | Zoomin | Zeom out

Execute] || ~| simtime: 0ns Time: 0 s Covered: 0777 Radie: ( Hex® Decimal

CLK ST

FSMI1 |

Wsreg Tot init

ol .

MRESET i3

i

Automatic Test Bench

v SaveWHOL Test Bench Az
|C:'\VHDL\ST.QTED‘3«D_SM1'\STATECQD\.SM'I_TB.VHD J

W Save Regression As:
|C:WHDL\STATED‘3«D_SM1'\STATECAD\SM‘I_TB.HEG J
Autarnatic test bench options

W EsitEffort(1.99) [5 =] | M RandomEffort (1.93) [20—]

[+ Returm Effart (1..39) ’@ Constrain Timing...

Test Bench Options
¥ Logresults ¥ Reporttotal erors W Auto verify outputs

Browser Control
' Default browser " Use pour browser:

Cancel
v Open automatically ,7 J Hel
Help
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Click Begin

& StateCAD HDL Browser - C:\WHDL\STATECAD, SM1\STATECADASM1_TB.VHD

File ‘iew

SE # %

CAVHDL\STATECAD SMT\STATECAD\SM1_TB.VHD ~
VHDL testbench created by

Kilinx's StateBench 1.01

Sun Mar 28 15:43:27 2004

LIBRARY ieee;
USE ieee.std_logic_1164.all;

LIBRARY ieee;
USE IEEE.STD_LOGIC_TEXTIO.ALL:
USE STD.TEXTIO.ALL;

ENTITY testhench IS
END testbench;

RCHITECTURE testbench_arch OF testbench IS
FILE RESULTS: TEXT 1S OUT "results.t<t'";
COMPOMENT SM1
PORT [CLK,EN,RESET: IN std_logic:
C: OUT std_logic);
END COMPONENT;

SIGNAL CLK,EN,RESET: std_logic :="0";
SIGNAL C : std_logic :="'0";

BEGIN

UUT : SM1 PORT MAP |
CLK=>CLK,
EN=>EN,
RESET=>RESET,
c=>C);

PROCESS
VARIABLE TX_OUT : LINE;
VARIABLE TX_ERROR : INTEGER = 0;

PROCEDURE CHECK_C[
next_C : std_logic
115 BEGIN

IF [C {= next_C] THEN
write[T>_OUT,string'[

" Error, C=");
write[TX_OUT, C];
write[T¥_OUT, string"[" Expected =");
write[TX_OUT, next_C];
write[TX_OUT, string"[" *);
writeline[results, TX_OUT];
TX_ERROR := TX_ERROR + 1;

END IF;

ASSERT [C=next_C] REFORT
"Error, C has incorrect value™
SEVERITY ERROR;

END;

BEGIN

CLK <='0" — Initialize clock inactive
EN <="'0"%

RESET <="1";

YWAIT FOR 15 ns;

CLK <="1"; — Clock 0 Time 15 ns

WAIT FOR 20 ns;

CHECK_C['0");

WAIT FOR 30 ns;

CLK <="'0"; — inactive clock edge

WAIT FOR 35 ns; 3

JReady

10
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B SM1.DIA - [VHDL] - StateBench(tm)

File ©Options View Help
TR .
o S TEL| [ & [0 = = =2 =22 [
Verify Signal SaveTest|  FRun Couerage | Constrain | Autamatic
Echavior Fiestart Feset Cyele i P Editor Bench || TestBench| | Statistics | Timing | Testhench Zoom n || Zoom Out
Execute | || | Sim time: 300 ns Time: 0 ng Covered: Radix: © Hex™ Decimal
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